EĞER


İnceleme Beğeni Favori Değerlendirme Ortalama Puan Yıldız Sayısı
295 0 0 0 0
Reklam Alanı
Türkiye'nin en popüler Excel Portalındaki içeriklerin en başında reklamınızın yayınlanmasını ister misiniz?
Reklam vermek istiyorum
=EĞER(mantıksal_sınama; [eğer_doğruysa_değer]; [eğer_yanlışsa_değer])
=IF(logical_test; [value_if_true]; [value_if_false])



AÇIKLAMA


EĞER Fonksiyonu mantıksal bir test gerçekleştirir ve testin sonucuna bağlı olarak DOĞRU ya da YANLIŞ şeklinde iki değer döndürür.

AMAÇ


Bir duruma bağlı sonuç üretmek.

SONUÇ DEĞERİ


DOĞRU ya da YANLIŞ

SÖZDİZİMİ


=EĞER(mantıksal_sınama; [eğer_doğruysa_değer]; [eğer_yanlışsa_değer]

ARGÜMANLAR


mantıksal_sınama : DOĞRU veya YANLIŞ olarak değerlendirilebilecek bir değer veya mantıksal bir ifade.
eğer_doğruysa_değer : [Opsiyonel] mantıksal_sınama, DOĞRU olarak değerlendirildiğinde döndürülecek değer.
eğer_yanlışsa_değer : [Opsiyonel] mantıksal_sınama, YANLIŞ olarak değerlendirildiğinde döndürülecek değer.

KULLANIM


Belirli koşulları test etmek veya değerlendirmek için EĞER fonksiyonunu kullanabilirsiniz. Fonksiyon, mantıksal sınamaya vereceğiniz karara göre DOĞRU veya YANLIŞ sonucunu verecektir.

Bir tabloda, bir sınav notuna göre "GEÇTİ" veya "KALDI" olarak sonucu yazdırmak istiyoruz. Alınan not'a göre 50 ve üzeri puan alanlar için GEÇTİ, altında kalanlar için ise KALDI sonucunu yazdıracağız.
İlk hücreye yazacağımız formül:

=EĞER(F4>=50;"GEÇTİ";"KALDI")

Aynı formülü, tersine çevirerekte yazabiliriz.

=EĞER(F4<50;"KALDI";"GEÇTİ")



İÇ İÇE EĞER KULLANIMI


Daha fazla koşulu test etmek ve daha olası sonuç elde etmek için, EĞER fonksiyonunu iç içe kullanabilirsiniz.
Her bir EĞER fonksiyonun mantığının doğru olması için dikkatli bir şekilde "iç içe" yerleştirmek gerekir.

Örneğin öğrencilerin aldıkları notlara göre harflendirme yapacak olursak:

=EĞER(F4<50,"F",EĞER(F4<65,"D",EĞER(F4<75,"C",EĞER(C6<85,"B","A"))))

EĞER fonksiyonunu, 64 kez iç içe kullanabilirsiniz.

MANTIKSAL İFADELER


Operatör Anlamı Örnek
= Eşittir A1 = B1
> Büyüktür A1>B1
>= Büyük ve Eşittir A1>=B1
< Küçüktür A1
<= Küçük ve Eşittir A1<=B1
<> Eşit Değildir A1<>B1

Desteklenen Excel Versiyonu

Excel 365 Excel 2019 Excel 2016 Excel 2013 Excel 2010 Excel 2007 Excel 2003

Diziliş Yapısı

mantıksal_sınama eğer_doğruysa_değer eğer_yanlışsa_değer

Daha önce yorum yapılmamış!

Yazdığınız uzunca Excel formülleri, formül çubuğumuza sığmıyorsa, farenizi formül çubuğunun alt kısmına getirip basılı tutmak suretiyle, aşağı doğru çekerek formül çubuğunuzu genişletebilirsiniz.

Formül alanını büyütme

Formül alanını büyütme

Bu işlemi daha hızlı yapmak için Ctrl + Shift + U kısayolunu kullanabilirsiniz.
Bu Özellik Kullanılarak Hazırlanmış İçerikler
İçerik Adı Ekleyen Tarih Tür
VE ile YADA Formülleri ve Kullanımları AhmetRasim 19 Temmuz 2020 makale
Maaş İcmali Özet Raporu admin 20 Mayıs 2020 dosya
Cinsiyet Bazlı İlk X Girenlerin Listesi admin 13 Mayıs 2020 dosya
Alt Alta Tekrarlanan Verileri Formülle Yan Yana Getirme orkmesb 14 Kasım 2019 dosya
Rastgele Takımlar Oluşturma admin 29 Haziran 2020 dosya
Listeye Yeni Eklenen Kayıtları Bulma ve Renklendirme admin 02 Mayıs 2020 dosya
Grafik - Performans Takibi 52779 01 Haziran 2020 dosya
İç İçe Eğer Kullanımı admin 02 Şubat 2019 makale
İç İçe Eğer admin 02 Aralık 2019 dosya
Kriter Bazlı Gelişmiş Filtreleme admin 26 Nisan 2020 dosya
Yıllık İzin Takip Çizelgesi admin 13 Aralık 2019 dosya
En Çok Tekrar Eden Metinleri Bulma privet 27 Haziran 2020 dosya
Koşullu Biçimlendirme ile Performans Gösterimi 52779 06 Haziran 2020 dosya
Ad Soyad Ayırma admin 07 Aralık 2016 dosya
Tablodaki Verileri Formüllerle Filtrelemek lordkisame 19 Mayıs 2020 sorular
Koşullu (Kriterli) olarak Benzersizlerin Listelenmesi 52779 19 Temmuz 2020 dosya
Formül Hatalarını Yok Sayma admin 20 Nisan 2020 dosya
En Çok Tekrar Eden Sayıları ve Adetlerini Bulma admin 27 Haziran 2020 dosya
Kısa Çalışma Ödeneği 7 Gün Hesabı Feyzullah 29 Nisan 2020 dosya
İzin Takip Çizelgesi Dashboard admin 01 Temmuz 2019 dosya
Kümülatif Toplam Almak admin 22 Nisan 2018 makale
Tür ve Kilosuna Göre Eşleşen Değeri Bulun admin 29 Nisan 2020 sorular
Yıllık İzin Dönemini Aylara Bölme Omer_BARAN 24 Haziran 2020 dosya
#SAYI/0! hatası nasıl düzeltilir admin 20 Nisan 2020 makale
Hastalık İzni Ve Tatil İle İki Haftada Bir Zaman Levha admin 20 Mart 2018 dosya
Hücre Seçilince Resim Olarak Detayları Açılsın admin 18 Temmuz 2020 dosya
Toplu Maaş Hesaplama admin 11 Haziran 2020 dosya
Benzersiz Sayısal Değerleri Ölçütlü Sayma admin 25 Nisan 2020 dosya
Eğer Formülü ve Kullanımı AhmetRasim 12 Temmuz 2020 makale
İsimlerin Baş Harflerinden Kısaltma Nasıl Oluşturulur? admin 30 Nisan 2020 sorular
Brütten Nete Maaş Hesaplama admin 17 Mart 2020 program
Dönem ve Bölge Bazlı Satış Rapor Özeti admin 02 Temmuz 2020 dosya
Geç Kalma Sürelerinin Derecelendirilmesi admin 29 Nisan 2020 dosya
Köprü Yöntemi ile Sayfa İsimlerini Listeleme admin 21 Ocak 2020 dosya
Apartman Aidat Çizelgesi admin 10 Aralık 2019 dosya
Kısa Çalışma Ödeneği admin 08 Nisan 2020 dosya
İş Takip Çizelgesi admin 17 Nisan 2020 dosya
Aynı Koda Ait Birden Fazla Değeri Listeleme admin 07 Nisan 2020 dosya
Mantıksal Fonksiyonlar admin 01 Mayıs 2018 makale
Solda Kalan Verileri Düşeyara İle Bulma admin 05 Ekim 2019 video
Boş Değilse Hesaplama Yapma admin 20 Nisan 2020 dosya
İki Saat Arasındaki Süreyi Hesaplama admin 01 Mart 2019 dosya
Ay Bazlı Ödeme Tablosu privet 06 Mayıs 2020 dosya
Kısa Çalışma Ödeneği Hesaplama 2020 gorkemguvez 26 Mart 2020 dosya
Birden Fazla Eşleşmeyi Ayrı Sütunlarda Listele admin 25 Nisan 2020 dosya
Tatil Günlerini Renklendirme admin 18 Haziran 2020 dosya
Ay Bazlı En Çok Satışlar ve Satıcılar admin 20 Haziran 2020 dosya
Netten Brüte Maaş Hesaplama admin 24 Kasım 2019 dosya
Excel İnterpolasyon Formülü admin 22 Ocak 2020 dosya
Benzersiz Adetleri ve Benzersizlerin Listelenmesi 52779 15 Temmuz 2020 dosya