04Mayıs

Excel formülleri eğer mantıksal işlemi

Excel’de eğer mantıksal işlemi ile birçok sorumuzun yanıtını bulabiliyoruz. Eğer ifadesi çeşitli programlama dillerinde de ingilizce yazımı olan ” if ” şeklinde karşımıza çıkıyor. Excel formülleri içerisinde kullanılan eğer işlemi de aynı şekilde bir şart ve sonucunda değer, değilse başka bir değer mantığıyla çalışıyor.
Excel formüllerinden eğer’in mantığı basit olarak böyle diyebiliriz.
Eğer nasıl kullanılır, şart ne olur, nasıl bir sonuç için nasıl bir formül yazmalıyız diye sorular olur diye basitçe açıklama gereği duydum, umarım ki maksimum faydayı elde ederiz.

=Eğer(Şart ; doğruysa_değer ; yanlışsa_değer)
Buradan da anlaşılacağı üzere eğer ifadesini direkt, şart ifadesini değişken olarak yazıyoruz. Yani her işlemimizde eğer kesinlikle yazılacak, şart ve doğruysa yanlışsa işlemleri de birer değiken olacak, şarta göre hareket edecekler…

Görsel bir örnekler yazımızı destekleyeceğiz ancak bunun için yapılmış bir metni excel.gen.tr adresinden alıyorum.

Burada B2 Hücresine işlem yaptırıyoruz, diyoruz ki A1′e gelsin yazılırsa tamam geliyorum, bir şey yazılmazsa hayır gelmiyorum sonucunu ver bize…

Gibi bu tür örnekler çoğaltılabilir.

Not:
Burada dikkat edilmesi gereken şey son örnekte yazılan ” geelsin ” dir. Bir harf bile yanlış olsa sonuç değilse ifadesiyle aynı olacaktır.

 Yazının Etiketleri  
    • Tuncay Karaaslan
    • 30 Ekim 2010

    Merhaba
    Sorunumuz şudur:
    70 rakamı standart bir sıfır değeridir.ve karşılığı 1000 rakamı ile eşitlenir.Bu rakamın altında kalan her bir rakam için yani:(69-68-67….01) gibi 10 rakam eksiltme yapılır. 70 Rakamının üstüne ise 10 eklenir.
    Yani: 70=1000; 69=990; 68=980; 67=970;……
    71=1010; 72=1020; 73=1030;……. gibi olacak şekilde bir excel formülünü nasıl meydana getirebiliriz?
    Selam ve saygılarımla.

    • Huri Ertugrul
    • 2 Kasım 2010

    Merhabalar;
    Makaleniz eğer fonksiyonunun kullanımı açısından oldukça açıklayıcı.Teşekkürler.
    Excelde bir hücre içinde şu ifadeyi oluşturmakta oldukça zorlanmaktayım.
    “eğer hücre değeri 50 ile 65 arasında ise hücre değerini 2 ile çarp.” Yardımcı olursanız gerçekten çok sevinirim. Kolay gelsin..

    • admin
    • 3 Kasım 2010

    Efendim merhabalar,

    Dediğinizi anladım lakin onu yaparken bir miktar zorlanabiliriz. Bu açıdan biraz deneme yapıp size daha detaylı bilgi vermeye çalışacağım.
    Yine de tahminim =EĞER(A50,A51) şeklinde bir gidiş yolu ile olabileceğine işaret ediyor. Sizden biraz zaman istiyorum.

    • admin
    • 3 Kasım 2010

    Merhaba Tuncay Bey,

    Belirttiğiniz işlemi salt eğer fonksiyonu ile yapmanız mümkün değildir. Bunun için işin içine makrolar girmelidir. Aksi halde bu işlem kesinlikle sonuca ulaşmaz. Makrolar ileriki konularda daha detaylı biçimde açıklanacaktır.

    • ucayhan
    • 7 Kasım 2010

    merhaba ben şöyle birformül yapmak istiyorum yardımcı olursanız sevinirim:
    A1 hücresinde yazılan harf X ise A2 hücresine 40 Y ise 45 yazmasını istiyorum,yani hücredeki karaktere değer verip hangi değeri girmişsem ona göre değeri otomatik girmesini istiyorum

    • Naz
    • 16 Kasım 2010

    Excel güzel bir program ve biz bu programı gerçekten çok seviyoruz

    • bir garip excel uzmanı
    • 1 Aralık 2010

    2009 yılının ilk yarısında neredeydiniz ki benim o zaman da çok ihtiyacım vardı bu siteye, çok teşekkürler.

    • ÖMER AKBULUT whitecloud
    • 4 Aralık 2010

    A1 İLE A11 HÜCRELERİ ARASINDAKİ HÜCRELERDE BOŞ HÜCRE OLDUĞU SÜRECE C1HÜCRESİDE BOŞ OLSUN. A1 İLE A11 HÜCRELERİ ARASINDAKİ HÜCRELERDE BOŞ HÜCRE KALMADIĞI ANDA(HEPSİ DOLU İSE “C1″ E “X” İŞARETİ KOYSUN..A VE C SÜTUNLARI AYRI SAYFADALAR…
    YARDIMCI OLURSANIZ SEVİNİRİM….

    • ÖMER AKBULUT whitecloud
    • 4 Aralık 2010

    soruma acil cevap yazabilecek varsa minnettar olurum….

    • admin
    • 6 Aralık 2010

    Merhaba ömer bey,

    ayrı sayfadaki işlemler için eğer yetersiz kalıyor. Zannediyorum ki makro kullanmak gerekecek.

    • AYŞE GÜL ŞAHİN
    • 5 Ocak 2011

    KAYDİ SAYIM : 1.000,00 ( 900,00 )
    FİİLİ SAYIM : 900,00 ( 1.000,00)
    SAYIM FAZLASI: EĞER FAZLALIK VAR İSE YAZSIN
    SAYIM NOKSANI: EĞER NOKSANLIK VAR İSE YAZSIN

    FORMÜLDE YARDIMCI OLMANIZI RİCA EDİYORUM…

    • excelsever
    • 30 Ocak 2011

    Word gibi bir şey mi bu excel ben çözemedim, yardımcı olmanızı temenni ediyorum. Şimdiden teşekkürler arkadaşlar.

    • Murat
    • 1 Şubat 2011

    Huri Bey!

    Bu formülü A1 Hücresi haricinde herhangi bir hücreye uygulayın ve A1 hücresine çeşitli değerler girerek deneyebilirsiniz… Kolay gelsin…

    =EĞER(VE(A1>=50;A1<=65);A1*2;A1)

    • arly07
    • 1 Mart 2011

    arkadaşlar şöle bi formül olur mu?

    excell sayfa 1de, 1. sütunda a1 den f1001 e kadar sayısal yeni kod değerleri var; 2. sutunda bu değerlerin yanında da a2 den f1002 ye kadar eski kod değerleri yazıyor; excell sayfa 2 de de a1 den f1001 e kadar yeni kod değerleri ve a2 den f1002 ye kadar eski kod değerleri var ama sıralama sayfa1 dekinden farklı; aynı zamanda da sayfa 2 de 3. sutunda a3 den f1003 e kadar açıklamalar yazıyor; benim amacım sayfa 2 deki açıklamaları sayfa 1 e çekmek bunun için de sayfa 2 deki sıralamanın sayfa1 le aynı olması gerekiyor yoksa teker teker kopyalamam gerekecek bu işlemi yapabilmek için nasıl bi formül lazım; ilgilenen arkadaşlardan minnetkar kalacağım, şimdiden teşekkürler..

  1. kolay gelsin
    bir hücreye eğer şu değerler arasındaysa şunu yaz, şu değerler arasında diğerini, şu değerler arasında da şunu yaz şeklinde bir formül nasıl yazarım. mesela 0-24 arası için 0, 25-44 arası için 1, 45-54 arasına 2, 55-69 arasına 3 , 70-84 arası için 4, 85-100 arası için 5 yaz şeklinde bir formül nasıl oluşturulabilir? yardım ederseniz sevinirim

  2. meraba; şimdi hoca bize bi ödev verdi de size sorucağım soru şu BKİ konusunu bana ayrıntılı olarak yazar mısınız pekk anlamadımda vede örneklede yapabilirmisiniz
    bana yardım ederseniz çok memnun olurum…..

    • £liff
    • 2 Haziran 2011

    bana bunu formüle çevirebilirmisiniz?………………………………………..

    =eğer A1 85′ten büyükse “taktir” küçükse “teşekkür”

    • beyaz resim
    • 24 Temmuz 2011

    merhaba tuncay karaaslan
    sizin sorunun cevabı eğer fonksiyonunda saklı değil ama oldukça basittir.
    sizin sayılarınız A sütununda (A1-A50 satırları arasında 50 sayı) olsun. şimdi bunların karşılıklarını B sütununda görmek istersek B1 hücresine
    =1000-(70-D2)*10 formülünü girdikten sonra hücrenin sağ alt kısmında bulunan tutamacından yakalayıp B50 nci satıra kadar sürüklemek gerekir

    • beyaz resim
    • 24 Temmuz 2011

    düzeltme =1000-(70-A1)*10 veya =300+A1*10
    özür!

    • beyaz resim
    • 24 Temmuz 2011

    merhaba huri ertuğrul
    =EĞER(VE(50<D2;D2<65);D2*2;"") burada d2 hücresi sizin sayılarınızdan herhangi biri

    • musa
    • 16 Ağustos 2011

    merhabalar, benim sorum eğerle ilgili. eğer bir soru cevaplandı ise yeşil boyalı, cevaplanmadı ise kırmızı boyalı olsun. teşekkürler…

    • Gurer Hizel
    • 4 Ekim 2011

    Merhaba, bi formul konusunda yardiminiza ihtiyacim var. Sorum su: sectigim hucreye a1 hucresi 15 ila 20 arasindaysa 1, 20 ila 25 arasindaysa 2, 25 ila 30 arasindaysa 3 yaz seklinde bir formul yazmam gerekiyo ama bi turlu cikamadam isin icinden. Yardimleriniz icin simdiden tesekkurler.

  3. Merhaba ,
    formüllerle aram iyi olmasına rağmen bir sorunu çözemiyorum acaba yardımcı olabilirmisiniz.Mantıksal operatörlerde birden fazla işlem yaptırmak istiyorum fakat #Değer sonucunu veriyor acaba yardım edebilirmisiniz ?
    örnek olarak =EĞER(D4=25;D4=50;D4=100;D4<999);0,3)))) bu formüldür .hata varsa lütfen yardımcı olurmusunuz..

    • crazyfish35
    • 9 Ocak 2012

    BeyazGülüm,
    İlk dört değerin hepsi sizin şartlarınız ise (D4=25;D4=50;D4=100;D4<999), son şartınız diğer üçünü kapsıyor zaten (D4<999). Sadece onu yazmanız yeterli: =EĞER(D4<999; 0,3)

    "EĞER" yanlış anlamışsam :) , biraz daha açıklayabilirsiniz.

    • ismail
    • 12 Ocak 2012

    hocam mrb şöle bi formule ihtiyacım var şimdi ben c2 ve c3 sütununa makro yardımıyla belirlediğim aralıklarda rastgele sayı üretimi yapıyorum fakat bu ürettiğim sayılar c2/c3 şeklinde işlem yaptığımda istediğim değer aralığını geçiyor her üretmede olmasa da bu aralığı geçtiğinde tekrar sayı üretmesini nasıl saylayabilirim böle bi kod var mıdır. yardımcı olursanız sevinirim.

    • ta4ri
    • 29 Şubat 2012

    Eğer ile ilgili söyle bir sorum var.Bir hücrede 10 karakterden oluşan bir metnim var.Onun en sağ karakteri(yani 10. karakter) eğer 0 ise yanındaki hücreye sıfır,1 ise bir yazan formülü istiyorum.Eğer den sonra direkt sağdan formülü yazarsam hata veriyor.O yüzden önce sağdan ile son değerlerini bir hücreye alıp daha sonra yeni aldığım hücreye göre eğer koşulu yapmak zorunda kaldım.Bunu direkt eğer içinde, sağdan için yeni bir hücre tanımlamadan yapmak mümkün müdür?

    • deniz
    • 19 Mart 2012

    Merheba, ben belli bir alanda grupsal olarak seçilmiş hücrelere bağlı olarak mesela A1:A10 ama afrklı bir grubun yani mesela F1:F10 toplam almak istiyorum =EĞER(A3:A217=”FİRMA1″;”TOPLA(F3:F217)”;”") şeklende girdiğim formülde #Değer hatası veriyor (formülü değerlendirdiğimde (A3:A217)bölümü hatalı olarak karşıma geliyor fakat başka ne şekilde yazacağım bilemiyorum, yardımcı olabilirmisiniz

    • serza
    • 19 Nisan 2012

    formülde yanlışsa şart atanmamış

    doğrusu =EĞER(d4<999;"0,3";"") şeklinde olmalı

  1. Geri bildirim yok.

Yorum yapın